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A basic tutorial on QGIS applications in meteorology 
 

1. Digitization: drawing forecast polygons 

Polygon drawing is a typical operation in weather and climate analysis. With the advance 

and availability of GIS software, producing forecast maps with GIS application has 

become more convenient. The objective of this section is to produce a forecast map with 

multi-category polygons using QGIS. 

 

The long-term release (LTR) version of QGIS is available at the URL: https://qgis.org. It 

is assumed that the user is able to download and install QGIS on his/her computer. 

In this tutorial, the LTR QGIS version 3.4.2 (Madeira) is used.  

 

First, launch QGIS. We need a basemap layer. Second, import the WMO_basemap.zip 

data that comes with this tutorial. To do so, click the Open Data Source Manager toolbar 

or CTRL + L, double-click WMO_basemap.zip, and 

double-click WMO_basemap.shp. A worldmap 

should now appear in the canvas. Close the Open 

Data Source Manager window. 

 

We are going to draw our forecast polygons over a given country. In our case, it is Nigeria.  

 

Right-click on WMO_basemap layer in the Layers panel, located to the left of the window. 

Click Filter. The Query Builder window should now appear. Select SHORT_NAME in the 

Fields section on the left of the window. Click All in the Values section to the right of the 

window. A list of countries should show up in the Values section. Double-click 

CNTRY_NAME, click the equal sign in the Operators section. Scroll down the list of 

countries in the Values section and double-click Nigeria. The window should look like the 

figure below. Click OK. The map of Nigeria should now appear in the canvas. Right-click 

https://qgis.org/
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on the WMO_basemap layer and click Zoom to Layer. The map should now zoom in and 

focus over Nigeria. 

 

Depending on your preference, 

you may change the color of the 

Nigeria map to grey. Right-click 

on the WMO_basemap, hover 

your cursor over Styles, and 

select grey #808080. 

 

The next step is to create a new 

and empty shapefile layer. Go to 

menu Layer > Create Layer > New Shapefile Layer. In the New Shapefile Layer window 

box, under File name, save the new layer as forecast in your preferred directory. Choose 

Polygon in the Geometry type. In the New Field section, type category in Name. Category 

would differentiate our planned polygons as above-average or below-average. Make sure 

that Type is Text data. Next, click the Add to Fields List button. Category should now 

appear in the Fields List section. 

 

Repeat the above step; but type 

this time prob, indicating 

probability in Name in the New 

Field section. Change Type to 

Whole number. Click Add to 

Fields List button and verify that 

id, category, and prob are in the 

Fields List. Click OK. 
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We are now ready to draw our first polygon. But, 

first, let’s add some additional toolbars to our QGIS 

editor. Click on menu View > Toolbars > Shape 

Digitizing Toolbar. New but inactive toolbars should 

now appear on the toolbar menu. 

 

To edit our 

polygons, click on the Toggle Editing, yellow pencil, 

toolbar. Once this Toggle Editing is clicked the 

digitizing toolbars become active. 

 

To draw a curved polygon, click on the Add circular 

string toolbar. This toolbar allows the user to draw a 

smooth and curved polygon by adding more vertices (nodes) automatically. Please note 

that a polygon is drawn by clicking on a starting vertex (node) and moving the cursor to 

the next one and so on. When satisfied with the shape, right click near the starting vertex 

to close the polygon. 

 

We are going to draw an above-average polygon over southern Nigeria and parts of the 

Atlantic Ocean. Start by clicking the first vertex over the ocean to the southwest of Nigeria. 

Click the next vertices while making a curve, continue, and repeat where a curved shape 

is needed. The user may have a polygon shape like the figure below right before the last 

vertex. Close the polygon.  

 



4 
 

Once the polygon is closed, a 

new form window pops up. This 

step consists of filling up the id, 

category, and probability that 

describe the first polygon. Type 

1 in the id fields. Type Above-

average and 45, in the category 

and prob field, respectively. Then click OK. The Above-average polygon should now 

appear over southern Nigeria. 

 

Next, we are going to draw a Below-average polygon across central Nigeria. Repeat the 

above steps from clicking the Add circular string toolbar, clicking the vertices, closing the 

polygon, to filling out the form. This time, type 2, Below-average, and 55 in the id, 

category, and prob fields, respectively. Click OK. The Below-average polygon should now 

be visible over central Nigeria. 

 

We may add another Above-average polygon that covers northeastern Nigeria and also 

parts of Cameroon, neighboring country. We draw the polygon in a manner similar to the 

first Above-average polygon over southern Nigeria. This time, type 3, Above-average, and 

50, as id, category, and prob, respectively. Click OK.  

 

We are now ready to save the polygons under the forecast layer. Click the Toggle Editing 

back and click Save. You now may have a forecast map with 3 polygons similar to the 

figure below. 

  

In most cases, it is desirable to 

have the polygons follow the 

country outline. QGIS has vector 

geoprocessing to do just that. Go 

to menu Vector > Geoprocessing 

Tools > Intersection. In the 

Intersection window, select 
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forecast as Input layer. Select WMO_basemap as Overlay layer. In the Intersection field, 

click … and save the output layer as forecast_intersect  and as a shapefile (SHP) in your 

preferred directory.  

Click Run. You should now see 

that the forecast polygons follow 

the country outline and are 

added as a new layer, called 

Intersection in the Layers panel. 

 

You may uncheck the box in 

front of the original forecast layer 

to make this layer disappear. 

You then may have a forecast 

map similar to the below figure. 

Please note that the polygons ‘default color may be different. 

 

Since the forecast polygons are 

undistinguishable from one 

another, symbology enables the 

user to classify the forecast. To 

do that, double-click the 

Intersection layer. The Layer 

Properties window should 

appear. Make sure that Symbology is selected on the left tab. 

 

Click the down-arrow to the right of Single symbol on the first line to the right of the window 

and select Categorized. Click the down-arrow to the right in the Column field and select 

category. Click the Classify button to the left of the + and – signs. Double-click and change 

the color for the Above-average and Below-average to green and brown, respectively.  
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Please also note that the user 

has a lot more controls with other 

properties such as Fill color, Fill 

style, Stroke color, etc. by 

clicking on Simple fill in the 

Symbol Selector window after 

double-clicking the color. Click 

OK to apply the color changes. 

 

Keeping the Layer Properties window open, click on Labels on the left tab. Click on the 

down-arrow to the right of No labels and select Single labels. Click on the down-arrow in 

the next line with Label with and select category. Click on Text below the Lorem Ipsum 

section and change Size to 14. Click Buffer under Lorem Ipsum and check Draw text 

buffer. Click OK. You should now have a map similar to the figure below. 

 

So far, we have our forecast 

map; but certain elements such 

as title, scale map, legend, north 

arrow, etc. may be missing. 

These could make the map 

easier to understand and 

interpret for the intended users . 

The mapping process enables the user to perform this task. 

 

Go to menu Project > New Print Layout or CTRL + P. The Create print layout Title window 

should appear. Click OK. A new Layout 1 window should appear. Maximize the window. 

Click on the down-arrow at the bottom right and select Fit Layout to fit the screen. 
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To add the map to the layout, go to menu Add Item > Add Map. Drag a rectangle on the 

layout by starting with the top left corner and leaving some margins for the title, 

coordinates, legend, etc. The 

forecast map from the QGIS 

editor should now appear on the 

layout. 

 

The size of Nigeria inside the 

map area may be too small. On 

the Item Properties tab to the 

right of the window, change the Scale to 6,000,000 or until an adequate size is obtained. 

 

To add coordinates and frame to the map, scroll down the Item Properties and click Grid. 

Click the + sign. Select Grid 1 and click the Modify grid button. In the Appearance section, 

in the Grid type, click the down-arrow and select Frame and annotations only. In the 

Interval, change X and Y to both 3. In the Frame section, change Frame style to Exterior 

ticks. Scroll down and deselect Right side and Top side. In Draw coordinates section, 

change Format to Decimal with suffix. Change Right to Disabled. Change Top to Disabled. 

Click Font and change Size to 14. Change Coordinate precision to 0. Click on the Go back 

button to the left of Map Grid Properties. Scroll down and check Frame.The coordinates 

should now appear like in the figure below.  

 

To add title to the map, go to 

menu Add Item > Add Label. 

Drag a rectangle on top of the 

map area. A box, with the text 

Lorem Ipsum should appear. Go 

to the Item Properties tab on the 

right, under Main Properties, 

replace  Lorem Ipsum  with Subseasonal Rainfall Forecast over Nigeria. Hit Enter for next 

line. Write valid 1 – 7 November 2055. Under Appearance, click Font and change Font to 
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Arial and Size to 26. In the 

Horizontal alignment and 

Vertical alignment, select Center 

and Middle, respectively. If the 

title box is too small, you may 

adjust the Height to an adequate 

size under Position and size. 

 

To add legend, go to menu Add Item > Add Legend. Drag a rectangle to the top right of 

the map. All layers in the QGIS editor will appear in the legend. The user can remove and 

change items on the legend. On the Item Properties tab, under Main Properties, type 

Category as Title. In the Legend Items section, uncheck Auto update. Scroll down to show 

the + and – sign toolbars under 

Legend Items. Click the extra-

color (blue in this tutorial) under 

Intersection layer, hold CTRL, 

click forecast layer, hold CTRL, 

then click WMO_basemap. Click 

the – sign to remove these 

selected items. Click the yellow 

pencil toolbar, delete Intersection, and click OK. Scroll down on Item Properties and check 

Frame.  

 

Go to the QGIS Editor and make 

sure that CRS is WPSG:4326 

(WGS 84). If not, click on the 

small globe button on the lower 

right of the window. In the 

Project Properties window, 
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select WGS 84 and click OK. Go 

back to the Layout 1 window. To 

add scale bar, go to menu Add 

Item > Add Scale Bar. Drag a 

rectangle to the bottom right of 

the map area. A scale bar should 

show up over the designated 

area. 

 

To add north-arrow, similarly, go to menu Add Item > Add Picture. Drag a rectangle above 

the scale bar. On the Item Properties to the right, expand Search Directories. Select the 

north-arrow of your choice. 

Other elements can be added to 

or modified on the map. When 

satisfied, export the map to your 

preferred location. Go to menu 

Layout > Export as Image or 

Export as SVG or Export as PDF 

according to your preference. 

 

2. Raster operations 

Many weather and climate data are nowadays available in GIS raster format. Raster data 

are gridded and georeferenced data. The objectives of this section are to perform 

mathemathical operations and clipping analysis on satellite rainfall estimate data. 

 

Use the Open Data Source Manager toolbar or CTRL + L to load in WMO_basemap, 

CMORPH_DLY_025deg_20140704_float; and  

CMORPH_DLY_025deg_20140705_float,  raster data that come with this tutorial. By  
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default, raster data are  

displayed in grayscale like in the 

figure below. Change the 

symbology of  

CMORPH_DLY_025deg_20140704_float by double-clicking the layer on the Layers 

panel. In the Layer Properties, under the Band Rendering section, change Render type 

to Singleband pseudocolor. Change Max to 100. Under Min / Max Value Settings, change 

Color ramp to Blues. Double-click the color that is associated with the 0 mm value. The 

Change Color window should 

appear and set Opacity to 0% 

and click OK. The figure should 

look like the following  figure. 

 

Repeat the same above 

procedure for 

CMORPH_DLY_025deg_20140705_float. 

 

To compute and display the 2-day rainfall totals across the globe, go to menu Raster > 

Raster Calculator. In the Raster Bands section, double-click 

CMORPH_DLY_025deg_20140704_float@1. It will appear in the Raster Calculator 

Expression section. Under the Operators section, click the + sign. Double-click 

CMORPH_DLY_025deg_20140705_float@1. In the Result Layer section to the right, 

save output file as cmorph_tot in your preferred location. Click OK. The 2-day CMORPH 
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rainfall totals layer should now appear in grayscale. Change the symbology of cmorph_tot 

using the same properties as 

those for the 

CMORPH_DLY_025deg_20140704_float and CMORPH_DLY_025deg_20140705_float. 

Verify that cmorph_tot is indeed the sum of the two original raster data by checking and 

unchecking the layers to make them visible or invisible.   

 

Now, let’s assume we are 

interested in analyzing rainfall 

totals over Nigeria only. First, 

filter the WMO_basemap, 

basemap, layer to show Nigeria 

only. 

 

To crop cmorph_tot over Nigeria, we use the QGIS clipping function. Go to menu Raster 

> Extraction > Clip Raster by Mask Layer. In the Clip Raster by Mask Layer window, make 

sure that Input layer is set to cmorph_tot and Mask layer is set to WMO_basemap. In the 

Advanced parameters section, under Clipped (mask), click … to the right and save the 

output file as a file as clipped_cmorph_tot. 
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Click Run. The clipped layer 

should now appear. Change the 

symbology of 

clipped_cmorph_tot, using same 

properties as before. The clipped 

layer may then look like the 

figure below. 

 

The user may then proceed with 

the mapping process if he/she 

wants to produce production-

level map.  

 

3. Interpolation 

Interpolation of station data is a 

typical and important operation 

in weather and climate analysis. 

 

The objective of this section is to 

interpolate dekadal (10-day 

period) rainfall totals from stations over Nigeria during early June 2014. 

 

First, import WMO_basemap, 

basemap, and filter over Nigeria. 

Second, Open Data Source 

Manager and click Delimited 

Text on the left tab. Under File 

name, browse to 

nigeria.2014061.csv. We note 

that this data was saved in Excel 

spreadsheet as Comma-

Separated Value (CSV) file. In 
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File Format, ensure that CSV is selected. In Geometry Definition, ensure that X field and 

Y field is Lon and Lat, respectively. Make sure that Geometry CRS is set to EPSG:4326. 

Click Add.  

 

The location of each station 

should now appear over Nigeria 

such as in the following figure. 

 

Next, save the station data as a 

shapefile. Right-click on 

nigeria.2014061, click on Export > Save Features As. Save output file File name as 

station_data and as shapefile in your directory. Then click OK. The station_data layer 

should now appear as a new layer. 

 

We are going to apply an Inverse Distance Weighted (IDW) interpolation to station_data. 

Go to menu Raster > Analysis > Grid (Inverse Distance to a Power). In the Grid window, 

Set Point layer to Station_data. In Advanced parameters, set Z value from field [optional] 

to Total. Click Run. The interpolated station data should look like the following figure.  

 

Please note that many other 

interpolation methods are 

available in QGIS. Most of them 

are accessible from menu 

Processing > Toolbox. 

 

Now, the user can again perform 

symbology, clipping, and mapping to produce a production-level map. 

 

For further documentation and training guide on QGIS, please feel free to access the 

URL:https://qgis.org/en/docs/index.html. Hands-on and practical tutorials are also 

available at the URL: http://www.qgistutorials.com/en/. 

https://qgis.org/en/docs/index.html
http://www.qgistutorials.com/en/

